Evergreen Post

Follow @sku_b on Micro.blog.

Looks like I upgraded my iMac at the right time. My 2011 model will not support Mojave. Think I’ll do a fresh install of High Sierra on it tonight since I’m going to use it as a server machine.